新闻资讯

CVE-2014-6271 bash远程命令执行漏洞

2014-09-16 Ever 8

近日爆出CVE-2014-6271 bash远程命令执行漏洞,GNU Bash 4.3及之前版本在处理某些构造的环境变量时存在安全漏洞,向环境变量值内的函数定义后添加多余的字符串会触发此漏洞,攻击者可利用此漏洞改变或绕过环境限制,以执行shell命令。某些服务和应用允许未经身份验证的远程攻击者提供环境变量以利用此漏洞。此漏洞源于在调用bash shell之前可以用构造的值创建环境变量。这些变量可以包含代码,在shell被调用后会被立即执行。

此漏洞可能会影响到使用ForceCommand功能的OpenSSH sshd、使用mod_cgi或mod_cgid的Apache服务器、DHCP客户端、其他使用bash作为解释器的应用等。攻击者利用此漏洞进行攻击的前提条件是直接使用bash或者通过网络协议与使用了特殊模块的一些服务进行通讯。

ACKOS安全操作系统具有以下保护措施,杜绝了受到此攻击的可能:

  • 使用自定义裁剪的Linux操作系统,仅包含必要的服务与应用。

  • 对网络通讯进行了严格限制,只有必要的数据包可以进出。

  • 使用了Apache服务器,但没有使用mod_cgi或mod_cgid。

  • 通过ssh/telnet/console登录到后台后,运行的是ACK自定义的命令行解析器,而不是通用的bash。

    ACKOS安全操作系统中没有给攻击者留下触发此漏洞的机会。